苹果A1369奇怪故障解决

来源:未知    发表时间:2014-04-30    浏览次数:

苹果AIR A1369 2011
板号:K21

故障:有时能亮机,有时亮机进系统死机.有时不能亮机.还有一个比较特殊的情况就是如果能亮机的时候,你键盘关机,再开机就会又不亮机.然后你再怎么开都不会亮了.不过奇怪的是你放一下板凉了,就又能点亮.以上都是可以触发上电不显.
今天天气真好,阳光明媚!但气温不高,出门还是感觉有点冷啊.
机器是前好多天接的了,是一人同行的.机器还不充电,后更换电池,电源头亮橙色灯.原来电池也坏了.我给他报了价,他就不理了.昨天过来说要修.昨天下午动手了.
目测机器桥和CPU下都有松香水的痕迹.桥的胶已经被除掉了.CPU没有除胶.当时我都在想,都除胶还加松香加焊什么.
故障很特殊,桥和CPU都被加焊过.我当时考虑是桥可能被他加焊坏了.我在上机不显示的时候测量了各大电感.发现CPU的集显供电L7550电感没电.如图

供电L7550电感
追查来源是U7400 MAX19052芯片控制输出的.
U7400 MAX19052芯片
此芯片控制两路PWM.另一路是CPU核心供电是1.1V,有正常输出.
说明这个芯片是OK的.有时能开机显示,说明集显供电L7550后级应该没什么大问题.我猜测是芯片不良,或是EN问题.
量测芯片工作条件:VCC VCCA VCCB CSPA3 TON都正常.EN的开启信号CPUIMVP_VR_ON也正常,但怎么就只输出CPU核心供电,没集显供电呢?一时没了思路,请教了饼哥.饼哥说集显供电是跑码后才有的,是SVID信号控制发出的.我就想着机器能正常亮机BIOS可能没什么问题.就查一下CPU的几个复位信号,看是CPU没工作,还是复位没有收到.

复位没有收到
查CPU_PWRGD PM_MEM_PWRGD_R PLT_RESET_LS1V1_L 这3个重要的PG和复位信号都有正常的高电平.怎么还不发出呢?还是怀疑桥被他搞坏了,不良时好时坏了.去换了一个全新桥,还不亮机了.心里毛了.放一边看一下其他板先.不久同行又过来催我了,说今天一定要修好给他.没办法啦,不修好太没面子了.拿板过来,一试既然能开机了.吓我一跳,以为桥没做好.多试几次涛声依旧啊.看了一下EC,有拆了胶,也拆下重植了一下.上电一样.又换了一个供电芯片,还是一样!没招了!我也一样搞了个三板斧,砍完了.
开始在群里跪求思路,求大神了.可大家都好忙,没空答理我.答理我的,也没可靠的思路.转眼一下午折腾过去了,下班了.我不是个轻言放弃的人.同行没来拿,我就把板带回去了,想着吃过晚饭再看看.
吃了晚饭了,请教了一下老板.我说了一下放冷一下能显示了.他说也有可能是有电容漏电.不好修..我也觉得不太可能,也没办法,换了集显那边的滤波电容.还是一样.
还是想思路吧....我还在想饼哥说的,跑码后才有的.那可能是CPU的工作条件不够.那就查CPU的全部供电吧.死马当活马医了.CPU供电很多,查了差不多20多分钟过去了.最后查到

如图R1010
如图R1010这个电阻.奇怪.怎么会没有呢?板上也是氧化,和出厂不装芯片电阻的地方一模一样.图纸上是有的啊..我都不太相信自己的眼睛了.不过我有张一样的板,我看了一下,是有的啊.不太相信,后来确认料号都是一样的.
补上吧..不会真的就是这个补偿电阻的问题?
补上后,试机.关机再上电都能显示了.成功修复
总结:INTEL的桥虚焊的可能性是很小的.有问题还是多查查图纸,多了解信号时序!

网上在线报名

*
*

联系方式

培训咨询①点击这里给我发消息

培训咨询②点击这里给我发消息

技术交流群迅维网官方群7